ChurchSuite - Regional service outage - Australia – Incident details

All systems operational

Regional service outage - Australia

Resolved
Partial outage
Started 3 months agoLasted 17 minutes

Affected

ChurchSuite Service

Partial outage from 9:19 AM to 9:37 AM

Connect

Partial outage from 9:19 AM to 9:37 AM

Embed

Partial outage from 9:19 AM to 9:37 AM

MyChurchSuite

Partial outage from 9:19 AM to 9:37 AM

API

Partial outage from 9:19 AM to 9:37 AM

ChurchSuite

Partial outage from 9:19 AM to 9:37 AM

Updates
  • Resolved
    Resolved

    This issue appears to have been a problem with one of our upstream providers CloudFlare; we have been informed it has now been resolved.

  • Investigating
    Investigating

    Some customers have reported unavailability of the ChurchSuite service which our developers are currently investigating. We apologise for the inconvenience and will post further updates on this page.

    This appears to only be affecting customers trying to access the service from Australia.