ChurchSuite - ChurchSuite is currently unavailable – Incident details

All systems operational

ChurchSuite is currently unavailable

Resolved
Major outage
Started 3 months agoLasted 16 minutes

Affected

ChurchSuite Service

Major outage from 10:39 AM to 10:55 AM

Connect

Major outage from 10:39 AM to 10:55 AM

Embed

Major outage from 10:39 AM to 10:55 AM

MyChurchSuite

Major outage from 10:39 AM to 10:55 AM

API

Major outage from 10:39 AM to 10:55 AM

ChurchSuite

Major outage from 10:39 AM to 10:55 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved, but our team will continue to monitor the infrastructure to ensure that it remains stable.

  • Monitoring
    Monitoring

    Our developers have implemented a fix and are monitoring the service status. You should see the service availability begin to return. We apologise for the inconvenience and will post any further updates on this page.

  • Investigating
    Investigating

    Our developers are investigating the cause of the unavailability of the ChurchSuite service. We apologise for the inconvenience and will post further updates on this page.