ChurchSuite - Investigating email deliverability – Incident details

All systems operational

Investigating email deliverability

Resolved
Degraded performance
Started 4 months agoLasted about 2 hours

Affected

Third Party Services

Mailgun - Email Services

Updates
  • Resolved
    Resolved

    Emails are sending as normal we're no longer receiving reports of undelivered emails.

  • Monitoring
    Monitoring

    Our mail service now seems to be sending emails as expected.
    We're still investigating the emails that were scheduled and sent earlier but were reported as not being received.

    We are still monitoring email deliverability.

  • Investigating
    Update

    Some emails are still being received, although with a large and unexpected delay. We would not advise you to resend emails. We are still monitoring the situation.

  • Investigating
    Investigating

    We have received reports that emails are not being received by recipients. We are currently investigating this incident.