ChurchSuite - ChurchSuite is currently unavailable – Incident details

All systems operational

ChurchSuite is currently unavailable

Resolved
Operational
Started 4 months agoLasted 25 minutes

Affected

ChurchSuite Service

Major outage from 1:30 AM to 1:54 AM

Connect

Major outage from 1:30 AM to 1:54 AM

Embed

Major outage from 1:30 AM to 1:54 AM

MyChurchSuite

Major outage from 1:30 AM to 1:54 AM

API

Major outage from 1:30 AM to 1:54 AM

ChurchSuite

Major outage from 1:30 AM to 1:54 AM

Updates
  • Resolved
    Resolved

    The issue has now been resolved and the service is now working as expected. If you are continuing to encounter errors please contact ChurchSuite support (support@churchsuite.com). We apologise for any inconvenience that this may have caused.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    Our developers are investigating the cause of the unavailability of the ChurchSuite service. We apologise for the inconvenience and will post further updates on this page.