ChurchSuite - Slow response times – Incident details

All systems operational

Slow response times

Resolved
Degraded performance
Started 6 months agoLasted about 1 hour

Affected

ChurchSuite Service

Degraded performance from 8:09 AM to 9:00 AM

Connect

Degraded performance from 8:09 AM to 9:00 AM

Embed

Degraded performance from 8:09 AM to 9:00 AM

MyChurchSuite

Degraded performance from 8:09 AM to 9:00 AM

API

Degraded performance from 8:09 AM to 9:00 AM

ChurchSuite

Degraded performance from 8:09 AM to 9:00 AM

Updates
  • Resolved
    Resolved

    There have been no further drops in response times and we're confident we understand what caused the issue in the first place. We believe this incident is now closed.

  • Monitoring
    Monitoring

    Everything looks to have recovered and response times are back to normal ranges. We'll continue to monitor things to ensure we're fully on top of this.

  • Identified
    Identified

    We've spotted some slower than expected response times and are in the process of investigating the issue.

    --

    We've identified where the problem was and have made a change to correct the issue. The change looks to have improved response times.