ChurchSuite - The problem has been idenfitied with navigation for some users. – Incident details

All systems operational

The problem has been idenfitied with navigation for some users.

Resolved
Partial outage
Started 6 days agoLasted about 4 hours

Affected

ChurchSuite Service

Partial outage from 9:30 AM to 1:21 PM

ChurchSuite

Partial outage from 9:30 AM to 1:21 PM

CharitySuite Service

Partial outage from 9:30 AM to 1:21 PM

CharitySuite

Partial outage from 9:30 AM to 1:21 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. You may need to close and reopen the ChurchSuite app to see all of your user modules again.

  • Identified
    Identified

    Our developers have identified the cause of the problem with the ChurchSuite service and continue to work on fixing it. We apologise for the inconvenience and will post further updates on this page.