ChurchSuite - Issues with email attachments – Incident details

All systems operational

Issues with email attachments

Resolved
Operational
Started 24 days agoLasted 2 days

Affected

ChurchSuite Service
ChurchSuite
Updates
  • Resolved
    Resolved

    Those who reported issues with uploading/viewing email attachments have confirmed they're no longer experiencing any problems and we're not receiving any new reports of problems.

  • Monitoring
    Monitoring

    We're receiving reports that affected users are now able to upload and view files again. We're continuing to monitor.

  • Update
    Update

    Filestack are continuing to work on a fix. They have confirmed that any attachments sent already will become available once a fix is implemented.

  • Identified
    Identified

    Our third party file storage service Filestack have identified regional SSL related errors on cdn.filestackcontent.com. Filestack are urgently investigating the issue and hope to provide more information shortly (https://status.filestack.com/).

    As a workaround we've identified that the majority of users experiencing the issue seem to be using a Virgin Media internet connection. Try switching to a mobile connection to download any attachments.

    We will continue to work with Filestack on this issue.

  • Investigating
    Investigating

    We've had reports that some people cannot upload/open email attachments sent via ChurchSuite. We are currently investigating the issue.