ChurchSuite - ChurchSuite SSL errors – Incident details

All systems operational

ChurchSuite SSL errors

Resolved
Major outage
Started 12 months agoLasted 27 minutes

Affected

ChurchSuite Service

Major outage from 5:11 PM to 5:38 PM

Connect

Major outage from 5:11 PM to 5:38 PM

Embed

Major outage from 5:11 PM to 5:38 PM

MyChurchSuite

Major outage from 5:11 PM to 5:38 PM

API

Major outage from 5:11 PM to 5:38 PM

ChurchSuite

Major outage from 5:11 PM to 5:38 PM

Updates
  • Resolved
    Resolved

    We have re-issued our SSL certificate, which has resolved this issue and brought the application back online.

    We have identified that the issue was caused by one of our service providers failing to auto-renew the SSL certificate. We have raised a ticket with their support team to investigate how this happened and to ensure this doesn't happen again.

  • Investigating
    Investigating

    We are investigating reports of SSL errors, which is affecting the availability of the service.