ChurchSuite - Investigating email deliverability reports – Incident details

All systems operational

Investigating email deliverability reports

Resolved
Operational
Started over 1 year agoLasted about 5 hours

Affected

Third Party Services

Mailgun - Email Services

Updates
  • Resolved
    Update

    We have now switched all accounts back to their default email service provider.

  • Resolved
    Resolved

    We have switched over to our backup email service, which is delivering emails reliably. Mailgun are still processing the backlog that had built up. We will continue to monitor things to ensure that deliverability is fully back to normal.

  • Identified
    Update

    We have switched all email sending over to our backup email provider. We believe all delayed emails will eventually be delivered, but if your email is time sensitive, we would recommend sending again. We will continue sending all emails through our backup provider until we are satisfied that the Mailgun issue has been fully resolved.

  • Identified
    Update

    Mailgun have confirmed that their queues are processing slower than expected at the moment, but as yet haven't been able to provide a timescale for the backlog to clear. We continue to be in direct contact with them, trying to resolve this as quickly as possible.

  • Identified
    Identified

    Based on the evidence we've gathered, we can see that Mailgun have confirmed receipt of the email to be delivered, but we're seeing some emails delayed by up to 3 hours. Our expectation is that all emails will eventually be delivered, but that there's a backlog that is currently being processing. Once we've had confirmation from Mailgun that this is the case, we will provide further updates.

  • Investigating
    Investigating

    We have received reports that some emails are not being delivered in a timely manner. Our integration with our email provider, Mailgun, suggests that they are successfully receiving the emails, but there is a delay in them reaching the inbox. We have reached out to Mailgun and are awaiting a response - we will provide further updates as we receive information from them.