ChurchSuite - Full outage – Incident details

All systems operational

Full outage

Resolved
Major outage
Started over 1 year agoLasted about 1 hour

Affected

ChurchSuite Service

Major outage from 8:46 AM to 9:52 AM

Connect

Major outage from 8:46 AM to 9:52 AM

Embed

Major outage from 8:46 AM to 9:52 AM

MyChurchSuite

Major outage from 8:46 AM to 9:52 AM

API

Major outage from 8:46 AM to 9:52 AM

ChurchSuite

Major outage from 8:46 AM to 9:52 AM

Updates
  • Postmortem
    Postmortem

    We have posted on our website about the issues we experienced over the weekend which you can find here: A word on this weekend's issues.

  • Resolved
    Resolved

    The issue has now been resolved and the service is now working as expected. If you are continuing to encounter errors please contact ChurchSuite support. We apologise for any inconvenience that this may have caused.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    Our developers are investigating the cause of the unavailability of the ChurchSuite service. We apologise for the inconvenience and will post further updates on this page.