ChurchSuite - Part of ChurchSuite is unavailable – Incident details

All systems operational

Part of ChurchSuite is unavailable

Resolved
Partial outage 30 %
Started 17 days agoLasted 40 minutes

Affected

ChurchSuite Service

Partial outage from 9:38 AM to 10:18 AM

ChurchSuite

Partial outage from 9:38 AM to 10:18 AM

Connect

Partial outage from 9:38 AM to 10:18 AM

Embed

Partial outage from 9:38 AM to 10:18 AM

MyChurchSuite

Partial outage from 9:38 AM to 10:18 AM

API

Partial outage from 9:38 AM to 10:18 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We are happy the service operation has returned to normal. If you continue to experience any issues please don't hesitate to get in touch with support@churchsuite.com.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We have identified the cause of the issue and our engineers are in the process of deploying a fix. Further updates will be posted to this status page.

  • Investigating
    Investigating

    Some customers have reported unavailability of the ChurchSuite service which our developers are currently investigating. We apologise for the inconvenience and will post further updates on this page.