ChurchSuite - ChurchSuite is currently unavailable – Incident details

All systems operational

ChurchSuite is currently unavailable

Resolved
Major outage
Started 1 day agoLasted about 2 hours

Affected

ChurchSuite Service

Major outage from 7:22 PM to 8:08 PM, Degraded performance from 8:08 PM to 9:05 PM

Connect

Major outage from 7:22 PM to 8:08 PM, Degraded performance from 8:08 PM to 9:05 PM

Embed

Major outage from 7:22 PM to 8:08 PM, Degraded performance from 8:08 PM to 9:05 PM

MyChurchSuite

Major outage from 7:22 PM to 8:08 PM, Degraded performance from 8:08 PM to 9:05 PM

API

Major outage from 7:22 PM to 8:08 PM, Degraded performance from 8:08 PM to 9:05 PM

ChurchSuite

Major outage from 7:22 PM to 8:08 PM, Degraded performance from 8:08 PM to 9:05 PM

Updates
  • Resolved
    Resolved

    The issue has now been resolved and the service is now working as expected. If you are continuing to encounter errors please contact ChurchSuite support (support@churchsuite.com). We apologise for any inconvenience that this may have caused.

  • Update
    Update

    We are continuing to work on a fix for this incident. Service has returned but performance may be degraded until fixes have been implemented.

  • Identified
    Identified
    Our developers have identified the cause of the problem with the ChurchSuite service and continue to work on fixing it. We apologise for the inconvenience and will post further updates on this page.
  • Investigating
    Investigating

    Our developers are investigating the cause of the unavailability of the ChurchSuite service. We apologise for the inconvenience and will post further updates on this page.